ZK. 00 EVO is Restored!

                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               Send comments to mostlymiata@gmail.com                                                                             


Other Links





Evolution Orange

2000 Miata L

00 EVO is Restored!



I finished the car today!


The mirrors may be a shade darker than the rest of the car, but in sunlight, you get many different shades of orange so they do not look odd.  They also came out beautiful!  Thanks again to Barry at Jackson Collision Center.


MM 00 EVO is Restored 1



I had to add some trim to the hardtop and clean all the windows on the car and top.  Then I took these pictures.  I will take more once the wheels are changed to the polished set and the car has been washed and waxed the first time.  I am not sure when that will be so here are the first pictures.


MM 00 EVO is Restored 2



MM 00 EVO is Restored 3



MM 00 EVO is Restored 4



MM 00 EVO is Restored 5



MM 00 EVO is Restored 6



MM 00 EVO is Restored 7



I found a couple of issues on the test drive.  The turn signals would not function and the A/C would not come on.  Both were major issues to me.  I suspected that I must not have connected something under the dash, but was not sure where to start. 


Since I recently purchased an OEM manual with the wiring diagrams, I used it to trace back to find common part for each circuit. 


The turn signals traced to the flasher, so I bought another one.  The signals still would not function.  


I then traced to the hazard flasher switch.  So, I removed the radio and found the switch connector had not been reconnected.  Abracadabra...the turn signals worked again!  


Next I started tracing the A/C circuit.  The compressor would not run, so I checked the compressor relay.  It worked fine.  


Then I traced it to the A/C Amplifier (whatever that is).  I pulled the heater control out of the dash and found the connector that should have been reconnected when the dash was installed.  


Now I have cold A/C.  That is a necessity that I never want to be without, especially with the hardtop on!

 


Vendor Links







Comments